DEB安装
社区
要在基于Debian的发行版上安装Odoo 10.0 Community,请以超级用户身份执行以下命令:
 wget的-O - https://nightly.odoo.com/odoo.key 易键添加-
 回声 “的deb http://nightly.odoo.com/10.0/nightly/deb/ ./” >> /etc/apt/sources.list.d/odoo.list
 apt-get的更新&& apt-get安装odoo
然后,您可以使用通常的apt-get upgrade命令来使您的安装保持最新状态。
企业
对于Odoo 10.0 Enterprise,请从“ 下载”页面获取软件包然后你可以使用gdebi
 apt-get install postgresql -y
 gdebi <path_to_installation_package>
或者dpkg(自动处理较少的依赖关系):
 apt-get的安装PostgreSQL -y
 dpkg -i来<path_to_installation_package> 这可能失败,缺少的依赖关系
易于得到安装-f #应该安装缺少的依赖关系
 dpkg -i来<path_to_installation_package>
这将安装Odoo作为服务,创建必要的PostgreSQL用户并自动启动服务器。
危险
要打印PDF报告,您必须自己安装wkhtmltopdfdebian存储库中提供wkhtmltopdf版本不支持页眉和页脚,因此无法自动安装。建议的版本是0.12.1,可在 wkhtmltopdf下载页面的存档部分中找到。由于Debian Jessie没有正式版本,所以您可以在我们的夜间服务器额外部分找到我们的 
组态
配置文件可以在这里找到 /etc/odoo/odoo.conf
编辑配置文件时,必须使用service以下命令重新启动Odoo 
$ sudo service odoo restart
重新启动odoo:好的
RPM安装
警告
在基于RHEL的发行版(RHEL,CentOS,Scientific Linux)中,必须将EPEL添加到发行版的存储库中,以便所有Odoo的依赖项都可用。对于CentOS:
$ sudo yum install -y epel-release
有关其他基于RHEL的发行版,请参阅EPEL文档。
社区
执行以下命令以在您的服务器上安装Odoo 10.0社区:
$ sudo yum install -y postgresql-server
$ sudo postgresql-setup initdb
$ sudo systemctl enable postgresql
$ sudo systemctl start postgresql
$ sudo yum install yum-utils
$ sudo yum-config-manager --add-repo = https:// nightly .odoo.com / 10.0 / nightly / rpm / odoo.repo
$ sudo yum install -y odoo
$ sudo systemctl enable odoo
$ sudo systemctl start odoo
企业
对于Odoo 10.0 Enterprise,请从“ 下载”页面获取软件包然后运行:
$ sudo yum install -y postgresql-server
$ sudo postgresql-setup initdb
$ sudo systemctl enable postgresql
$ sudo systemctl start postgresql
$ sudo yum localinstall odoo_10.0.latest.noarch.rpm
$ sudo systemctl enable odoo
$ sudo systemctl start odoo
危险
要打印PDF报告,您必须自己安装wkhtmltopdfFedora / CentOS存储库中提供wkhtmltopdf版本不支持页眉和页脚,因此无法自动安装。使用wkhtmltopdf下载页面上提供的版本 
组态
配置文件可以在这里找到 /etc/odoo/odoo.conf
编辑配置文件时,必须通过SystemD重新启动Odoo:
$ sudo systemctl restart odoo
视图
1 总浏览
1 成员的观点
0 公众浏览
动作
0 喜爱
0 不喜欢
0 注释
分享到社交网络
分享链接
通过邮件分享

登录 分享这个 webpage 通过电子邮件。

评分
0 0